EA Alpha 1.2 Bugs! Comments! Discussions!

Topics and posts about The Tower.
User avatar
Consortium Administrator
Posts: 1013
Joined: Thu May 05, 2011 3:05 am
Location: Vancouver, Canada

EA Alpha 1.2 Bugs! Comments! Discussions!

Post by GreatBird »

This version brings a ton more bug fixes, many of which were discovered by many of you awesome people playing out there. Thank-you!!

A couple notes and known issues:
-The Lobby level is still undergoing fixing, polishing and optimizing. A bunch of improvements to it are included in this version, but more is to come soon.
-We have just discovered some major issues with nanite fragments. Not letting this delay the build for you folks, but just know it will be fixed in the next update. :)

We hope you enjoy!

Early Access ALPHA 1.2 (Rev #4554)


[Update] A bunch of front-end improvements. Can now properly name your universes, font changed up across the board. Corrected the new universe flow: Now goes (Name universe -> Agree to disclaimer -> Choose C1 save import if available -> Start game)
[Update] The entire Consortium Bishop HUD has received updated visuals. New fonts, newly colored elements. Enemy info reticles also updated. Going for more clarity overall. Based on data received from iDGi-1 about how the HUD actually appears to a Bishop.
[Update] Freefall Suit now starts with only 2 hardpoint slots, B.U.S. starts with 4. More can be added via upgrades.
[Update] Hovering over broken items with repair wrench shows energy required to repair. Same with how much given for recycling, and how much usage for healing.


[Update] Intro freefall improved - missing scene added. Still much more polish and a surprise to come later.
[Update] Freefall Suit Convo Manager is now added at the same time as "What is going on?!", when the player lands to lessen overloading the player at the very start of the game.
[Update] Top of Tower 2 patrol nodes improved from player feedback. Tweaked node wait times.
[Update] Some balancing adjustments to EM and Utility Energy yields from element containers.
[Update] Added proper Nanite Ambient sounds to Hotel Tower 3.
[Update] Level design improvements to Hotel Tower 3 -- addresses issues of elevator shaft and long vertical vent that could cause players with no utility energy to get stuck.
[Update] General fixes and changed conditions to high level Talk Anywhere. It should now be a bit less fidgety to talk anywhere to enemies.
[Update] Brush crunch sound volumes have been properly placed in the Hotel Park.
[Update] Using fancy name instead of actor ID for alignment change indication.
[Update] A little “up arrow” icon is now displayed over each potential upgrade, making upgradable stats much clearer.
[Update] Tweaks to CMC dialog heard when landing after missing the roof.
[Update] Some slight geometric fixes to TopExt. Helping AI pathing. Added a special walkable blocking volume near BPs_Ladder_LadderBP26 so even if the ladders still don't play along nicely with their enhanced push, the player can still leave that area.
[Update] Implemented CEAR upgrades for blast range and blast utility usage over time
[Update] Added and changed up a few of the TopExt Save spheres
[Update] Added a turret to the first vents of Hotel Tower 3 so players can't venture too far without equipment.
[Update] Fixed some scripting logic in Hotel Tower 3 so Malcolm doesn't just stand there if the player leaves through the vents before he finishes.
[Update] Modified a few Bishop Death ending descriptions.
[Update] The TopExt music now fades out once the player enters Hotel Levels.
[Update] Better organized the talk anywhere system to stop combat in TopExt


[Fix] Save Spheres now disable and then enable when a player loads, or unloads a level. This prevents major breakage from occurring for saved games that were created by the player while levels were streaming in our out
[Fix] Level design updates fixing two player "softlock" possibilities in HotelTower3 (including a new toggleable fan to go UP a long vertical vent section).
[Fix] Added some missing automap sections of the Tower3 elevator shaft
[Fix] Worked around a bizarre “as yet not fully solved” bug where loading into the roof from just certain save spheres would cause Elon to become invisible
[Fix] Moved rooftop Save Sphere that would cause the player to be stuck when loading.
[Fix] Fixed major issue where sections of the lobby would stream in while in the WaterHub or the TTCore, causing all kinds of broken havoc.
[Fix] Fixed major save/load bug where a level that had all combatants cleared out of it would spawn combatants again after loading. (thx to FordGT90Concept for save file!)
[Fix] Fixed Icer scene logic that plays when Squad Leader C is no longer present in game world.
[Fix] A bunch of major issues transitioning between the WaterHub and the Lobby fixed.
[Fix] Various issues with levels not streaming in correctly in the WaterHub fixed
[Fix] Fixed issue where sections of the Lobby could be streamed out erroneously
[Fix] Important fix for the Icer scene where in some easily achievable scenarios, the player could be locked into the icer scene effects. Friendly lock on, strange audio (likely video) effects active.
[Fix] Prevented a repeating conversation if the player loads in TopExt after the rooftop has been sabotaged, but they did not get the mission to find Elon from Wade.
[Fix] Moderate geometric fixes in the Hotel Lobby.
[Fix] Fixed issue with upgrading indication not working for more than one item at a time
[Fix] Various NPC alignment related bugs and quirks cleaned up
[Fix] Fixed some geometry in G11_WaterHub_LowerRooms_Transition to make movement between the levels far easier.
[Fix] Added ambient to dilated sound class master
[Fix] Hiding CMC and conversation manager if the CMC is not equipped
[Fix] The iDGi-1 tunnel found at the bottom of TTCore is now accessible as it’s supposed to be
[Fix] Fix for repair thresholds being zero'd on first spawn with broken items (which caused, among other issues, instantly “repairing” gear by putting them into a storage unit)
[Fix] Ensuring loaded armor gets their max health values set based on upgrades
[Fix] Fixed some TopExt VentMaze issues where some wind boxes could cause situations where players could get stuck.
[Fix] Turret inside TowerA can no longer erroneously engage soldiers if the TowerInside sub-level wasn't loaded.
[Fix] Only the player will now trigger the security turrets CMC line.
[Fix] Unrepairable Mysterious Device is no longer required to be repaired for the Repair equipment mission to be completed.
[Fix] Talk anywhere [44] ("Hey, why aren't you shooting at me?") gets properly removed again when combat initiates, or when talkables are registered as unavailable
[Fix] Fixed collision of the TT Core level's 'elevator' platforms.
[Fix] Fixed a strange bug where sometimes the Hotel Lobby earthquake and missions could repeat
[Fix] Fixed some geometry that prevented players from entering an important vent in Hotel Tower 3.
[Fix] Fixed the on/off state of a very vital fan in Hotel Tower 3.
[Fix] Fixed some phantom geometry in the Lobby (ongoing)
Do, or do not. There is no try.

-- GreatBird --
User avatar
Posts: 603
Joined: Thu Mar 03, 2016 10:36 pm
Location: IA

Re: EA Alpha 1.2 Bugs! Comments! Discussions!

Post by FordGT90Concept »

Edit: Oct 18, changing all videos to links to improve page performance...

I'm free, free fallin'!

Bottom of VXY antenna tower, there was apparently a party I wasn't invited to. After a while, they dispersed...still...
► Show Spoiler
This dude has messed up forearms on the roof...
► Show Spoiler
Roof cleared!
► Show Spoiler
SOS message interrupted conversation manager again.

Started Icer event and *somehow* a guard spawned and walked from behinds toward the icer. Result...
► Show Spoiler
Loaded a save for obvious reasons, got through it without that uninvited guest showing up.

Frank McFranky has a weird "No, of course not" response in the conversation. When he shows up: F1 -> F3 -> F2 -> F1 "No, of course not." That response doesn't make any sense given the context.

After the Icer conversation, I saw the blip that there's a new message, expand it, and there's nothing there...
► Show Spoiler
"The Icer" eventually showed up in the conversation manager. Then "Phase Fields."

Kite around the Park -> Voice -> Lobby...

Upon arrival in the lobby, I heard a turret and guard going at it. Once the turret exploded, K15 said "good work six." Wait, what?

The "P.C.U. Alterations" convo is repeatable when it shouldn't be. Upon loading a save after it showed up the first time, it causes the new message pulse as well so everytime you reload, it wants you to play it again.

If you go down the stairs from the ice cave door, turn around, and try to get back up, the step size is too big to make it. Gives the impression of an invisible wall even though there isn't one there...
► Show Spoiler
Performance is still really bad in the lobby (like alphatest 1.1 was better) and there's a lot of invisible walls. To add to that, I recorded the lobby for over 40 minutes and was forced to restart the game because streaming...broke. It got to a point where major walls/floors weren't displaying even in areas where it was working fine before. Reloading the save fixed it for the most part but there are still a lot of invisible walls.

There's a lot of collision issues in the Lobby and I mean a lot. I think most might be the aforementioned invisible walls but it really needs a clean up pass to find an eliminate the obvious ones (and there's a lot).

I started an upgrade the KAR (bar showed it was upgrading) when it was equipped, swapped to CEAR (bar copied over showing it was upgrading when it was not), then swapped back to KAR. The upgrade bar got stuck on KAR:
► Show Spoiler
A similar issue appears with upgrading freeflight suit, then swaping to BUS, and back again. Freeflight suit's upgrade bar is copied on to the BUS.

These stairs. I don't even. Architecture fail. XD
► Show Spoiler
Hey, look, it's snowing inside! Wish I was recording when this happened but I wasn't.
► Show Spoiler
These tables in one of the corners of the lobby aren't recyclable:
► Show Spoiler
The modified assault blaster is missing an image. I'll also reiterate that the image for the assault blaster is bland compared to the other guns.
► Show Spoiler
There's a lot of recyclables on the main lobby floor that can't be recycled. Here's pictures of some (tried to take pictures so landmarks in the distance gives you an idea where it is):
► Show Spoiler
When I snuck up on Preban, there was a *mess* of dialog. R25, K15, and R9 were talking over Preban talking with his guards. I may have even heard some random guard banter on top of that.

Preban "talk anywhere" remained after he was sneak incapped.

Preban had no inventory after sneak incap. He just dropped the assault blaster he was carrying and that's it. No inventory means no red transponder. I gave myself one to proceed...

Knocked out 43 guys in the lobby. No kills. Didn't get any message from Zenlil crew about being a badass ninja. :( I believe I heard two turrets firing at different times. Possible that the rooftop bug with the counter happened here too? If I missed someone, man, the lobby is huge! Finding one guard in there that I happened to miss is like searching for a needle in a haystack.

Here's eight videos of bugs in the lobby. I tried to start recording each one at a landmark then go to the bug so you can see where it is. The title of each video should explain what I'm trying to show...
https://youtu.be/ogbIYhXdFPM https://youtu.be/YxaZVMUWGog https://youtu.be/ehfRevbqcsU https://youtu.be/YJMa-4_GHz0 https://youtu.be/8CoRhyMtkmI https://youtu.be/u-yumzN9zsA https://youtu.be/HsD6F5EEyzg https://youtu.be/Qc8jfaNwx_8

Edit: Oct 15


Going down?

South red transponder elevator didn't do anything.

Went down the north red transponder elevator and got trapped. Here's final stats (remember 30 incaps are from CG1)...
► Show Spoiler
And when I tried to "Enter: None?" tunnel by the power core, game effectively locked up:
► Show Spoiler

Edit: Oct 15 - Loaded save before "Going Down?" to explore the Park via yellow transponder elevator up.


Videos of specific bugs:

This one is probably not specific to the Park but I found it in the Park so including it here. If you hit the stand button while in a duct and move past an area where the stand can animate, you'll end up standing up inside the duct on the opposite side. Solution may be to not allow standing at all inside of ducts (duck-jump is usually better anyway in the ducts):

The handrails on the stairs next to the save point in the Park are comically small:
► Show Spoiler
I got dicked by turrets which I will investigate further but I found it odd the game gave me a ranking of "conciliator" when I literally only talked once and that was to summon the icer on the roof. I should have the ranking of "ghost" or "ninja" or, better yet "ninja cop" because never detected and a lot of incapacitations. Considering the body count, conciliator isn't really applicable...
► Show Spoiler
The OP turret is in the corner of this video. Also, there's a static recyclable here that can't be recycled:
Here's a video I took from the beginning for just the OP Turret. It isn't OP until I run around the middle bit:

A bunch more non-recyclables at the end of this video:

Water Treatment Plant

I jumped in the pipe I'm looking at the start of the video and jumped back out. Ever since I did that, there's an underwater audio filter applied to everything. It doesn't trigger off when leaving the water.

I couldn't swim out of the water in the pool below the above video. Ended up getting "brute force trauma" on one of the non-moving blades. :shock: That said, it really isn't conveyed to the player that this pool is meant to be instadeath.

Loaded the save I made just before I jumped in the water and died...I apparently have a pretend KAR now:
► Show Spoiler
Here's the save I loaded:
(3.78 MiB) Downloaded 304 times
I assume this propeller is supposed to be instadeath but it isn't.
The propeller at the beginning also isn't instadeath when it should be. In both cases, you get trapped because of the currents so it's effectively game over anyway.

R9's lines in the water tunnels are playing twice. "Diversion switches" one did twice and so did the dialog before that. Here's a video of a third location here he did it (at the end):

I'm not liking this "diversion switch" minigame because there's not enough feedback. The switches don't visually appear to do anything and to check if they did do something, you have to jump into the water and look yourself and get back out again. The whole running back and forward is tedious. There should be a visual indicator in the room showing which fans are on and off that way you can just quickly turn and look at the result. That way you only have to go down there once you've solved the minigame. The way it is now...I'd rather not even bother.

General Bugs

I was never able to complete the repair-your-stuff side objective. I verified everything was at 100%, even dropped the PPCU, and it didn't trigger. Does it stop checking for this outside of the roof? I never dropped the PPCU until I was in the lobby. On top of that, PPCU still shouldn't be counted for the objective since it is not repairable.

Can't drag and drop ammo on the same type of ammo in an external PCU socket. I tried to copy a stack of AP ammo over and it would only accept it in the PCU general storage area. It did approriately transfer it to the external sockets but kind of annoying that it won't just fill let you drop and only fill up that specific socket.

Connected to above, I had over 600 bullets worth of ammo spread across the three available external PCU slots. I pulled out my KAR to kill a turret and it flashed "no ammo." When I tried to fire it, it switched me to CEAR. I switched back to KAR and it again flashed "no ammo" but this time, it successfully fired. I really don't understand what's happening here. This particular bug persisted until the end of my game.

The upgrade tab appears on ammo and it displays the same text as the info tab. Kind of a nitpick but...

Probably stating the obvious but I don't think stealth node is fully implemented yet, especially the upgrades. With stealth node enabled, I literally didn't exist to the AI (couldn't hear me and couldn't see me). I assume that's changing...

Edit: Oct 15

No "Fullscreen Borderless" option in video options?

Video options is showing display settings my monitor doesn't support. I assume this is meant to be used with scaling so you can oversample. Finding this kind of odd because most games don't blatantly support that like CG2 is right now.

The main screen animation stretches to fit 8:5 resolutions (goes from circle to oval):
► Show Spoiler
The user interface doesn't show the 5th nor 6th shield charging. I have five equipped here:
► Show Spoiler
The UI also doesn't reflect when an enemy has five or six shields. It shows the first four going down but the fifth is invisible.

PPCU has medical and repair nanite upgrades available for it...

When hovering the mouse over the close button of the conversation manager, it lights up the public opinion part too and the right side of the public opinion part has a strange color to do it:
► Show Spoiler
I changed windowed resolution to 1920x1080 and my monitor is 1920x1200. When I hit alt+enter, there's a scaling problem. Video showing this...
...Can see "Close" getting cut off in the options too.

Edit: Oct 18: the problem is changing aspect ratio between the two. For example, 1650x1030 (8:5) windowed and 1920x1200 (8:5) fullscreen works fine.

The Public Opinion dropping x% from just standing there doing nothing even applies when deep inside the Tower. How would the public know that you've been standing around doing nothing? I could see getting negative alignment from your current handlers but public opinion dropping only makes sense on roof where they can see you're not doing anything.

General Feedback

I used the freefall suit almost exclusively for my entire stealth incap play. Mobility is important and armor is not so using the BUS makes zero sense; however, I was very, very, very disappointed to discover the taser could not be upgraded from Level 0. So disappointed. Historian already made it clear that he doesn't like this idea but I think the freefall suit upgrades should reflect it as the defacto stealth suit where BUS should have combat bias. For example, an easy solution would be to replace the freefall suit's armor upgrade with the taser upgrade. To add to that, I think the taser level 1 upgrade should be one of the first upgrades. It's natural to go from the Voice directly into a the Lobby where there's a lot of guards with 4 shields. Being able to knock them out in less than 26 seconds (and a lot of energy) would be nice.

I recommend adding better visual cues when the tactical HUD and/or stealth node is enabled. For example, an icon in the lower left corner of the screen that clearly indicates what is enabled. Maybe like a passive energy usage indicator not unlike an information cluster in a car.

Turrets hiding when they're almost dead is still super annoying. :(

Edit: Oct 15

In CG1, the gun that appeared in enemy PCU was also the gun equipped. Most of these guys have two guns (one in reality and one in PCU). I like how CG1 was consistent with this (recycle gun in inventory was the same as recycling the gun in reality). It would solve the problem of them often lying on top of the gun when they go down.
Last edited by FordGT90Concept on Wed Oct 18, 2017 1:33 pm, edited 2 times in total.
► Show Spoiler
User avatar
Posts: 603
Joined: Thu Mar 03, 2016 10:36 pm
Location: IA

Re: EA Alpha 1.2 Bugs! Comments! Discussions!

Post by FordGT90Concept »

I gave up on the water treatment plant. I ran into too many broken switches or switches not clear in what their purpose is. I'm also not sure what the end purpose of doing all that is so...I figure my time is better spent elsewhere.

I saw a platform before entering the treatment plant so I decided to give it a go...

Two turrets fear me (as they should bahahahaha):
Here's the save for that in case it matters...
(3.73 MiB) Downloaded 309 times
Game crashed trying to go from Hotel Rooms into the Hotel Park...

Code: Select all

Assertion failed: bRegistered [File:d:\unrealengine_idgi\Engine\Source\Runtime\Engine\Private\Components\ActorComponent.cpp] [Line: 722] 

thetower!FDebug::AssertFailed() [d:\unrealengine_idgi\engine\source\runtime\core\private\misc\assertionmacros.cpp:349]
thetower!UActorComponent::BeginPlay() [d:\unrealengine_idgi\engine\source\runtime\engine\private\components\actorcomponent.cpp:723]
thetower!AActor::BeginPlay() [d:\unrealengine_idgi\engine\source\runtime\engine\private\actor.cpp:3113]
thetower!AActor::DispatchBeginPlay() [d:\unrealengine_idgi\engine\source\runtime\engine\private\actor.cpp:3097]
thetower!ULevel::RouteActorInitialize() [d:\unrealengine_idgi\engine\source\runtime\engine\private\level.cpp:1765]
thetower!UWorld::AddToWorld() [d:\unrealengine_idgi\engine\source\runtime\engine\private\world.cpp:2147]
thetower!UWorld::UpdateLevelStreamingInner() [d:\unrealengine_idgi\engine\source\runtime\engine\private\world.cpp:2780]
thetower!UWorld::UpdateLevelStreaming() [d:\unrealengine_idgi\engine\source\runtime\engine\private\world.cpp:2846]
thetower!UGameViewportClient::Draw() [d:\unrealengine_idgi\engine\source\runtime\engine\private\gameviewportclient.cpp:1148]
thetower!FViewport::Draw() [d:\unrealengine_idgi\engine\source\runtime\engine\private\unrealclient.cpp:1185]
thetower!UGameEngine::RedrawViewports() [d:\unrealengine_idgi\engine\source\runtime\engine\private\gameengine.cpp:491]
thetower!UGameEngine::Tick() [d:\unrealengine_idgi\engine\source\runtime\engine\private\gameengine.cpp:1246]
thetower!FEngineLoop::Tick() [d:\unrealengine_idgi\engine\source\runtime\launch\private\launchengineloop.cpp:3045]
thetower!GuardedMain() [d:\unrealengine_idgi\engine\source\runtime\launch\private\launch.cpp:166]
thetower!GuardedMainWrapper() [d:\unrealengine_idgi\engine\source\runtime\launch\private\windows\launchwindows.cpp:134]
thetower!WinMain() [d:\unrealengine_idgi\engine\source\runtime\launch\private\windows\launchwindows.cpp:210]
thetower!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264]
(389.33 KiB) Downloaded 289 times
The log in there is massive (18 MB) and I haven't been playing very long. I don't think they're related to the crash but it looks like something is doing something the engine doesn't like.

Edit: This crash is reproducible. Load up the save, jump a floor, run across the area to the Hotel Rooms door, open, jump up again, and try to use the door to the Park. As it tries to Stream, crash!

Edit: Video of making it crash with the save...
► Show Spoiler
Consortium Officer
Posts: 10
Joined: Thu Oct 06, 2016 11:25 am

Re: EA Alpha 1.2 Bugs! Comments! Discussions!

Post by Tomato78 »

1) Where's the light?
► Show Spoiler
2) Health and Stamina text looks unnatural in bars
► Show Spoiler
3) Raw Nanite Material - no subtitles
► Show Spoiler
4) Fans switches are not animated
► Show Spoiler
5) Fans are not so dangerous, player can swim through them
► Show Spoiler
6) After this fans dialogs are pronounced two times
► Show Spoiler
7) Player can stuck in such doors. Door in this place not open :(
► Show Spoiler
8) Double door
► Show Spoiler
9) Player can stuck here
► Show Spoiler
10) Area isn't showed on map
► Show Spoiler
11) Strange levers, some of them are doubled, what do they change - unknown
► Show Spoiler
Consortium Officer
Posts: 10
Joined: Thu Oct 06, 2016 11:25 am

Re: EA Alpha 1.2 Bugs! Comments! Discussions!

Post by Tomato78 »

12) Multiple and fast press of N don't hide open N bar
► Show Spoiler
13) Auto-map artifacts - I can see areas behind others
► Show Spoiler
14) Have no information about - what this lever change... maybe it's hardcore part? to find what the lever turned off?
► Show Spoiler
15) I can't move through this door - player's too fat
► Show Spoiler
User avatar
Posts: 603
Joined: Thu Mar 03, 2016 10:36 pm
Location: IA

Re: EA Alpha 1.2 Bugs! Comments! Discussions!

Post by FordGT90Concept »

Requested save for the "diversion" propellers defaulting to a pattern where the player can easily pass through (#5 on Tomato78's list too):
(3.87 MiB) Downloaded 488 times
► Show Spoiler
User avatar
Posts: 603
Joined: Thu Mar 03, 2016 10:36 pm
Location: IA

Re: EA Alpha 1.2 Bugs! Comments! Discussions!

Post by FordGT90Concept »

Put this on Discord, putting here for posterity...

Suggestion: no way to climb using freeflight suit without looking up. Suggest changing "jump" to climb and disable freeflight suit to "use."

Suggestion: Make "Move On" red if it's going to go straight to combat. Talking Elon convo. Alternatively, make Move On listen to and accept his deal.

Bug: I did Move On with Elon on two separate fresh starts: first time they aggro'd and didn't fire:

Second time they aggro'd and fired, but didn't do any damage:
► Show Spoiler
User avatar
Posts: 603
Joined: Thu Mar 03, 2016 10:36 pm
Location: IA

Re: EA Alpha 1.2 Bugs! Comments! Discussions!

Post by FordGT90Concept »

I tried going around the rooms/park transition crash. No problem there as previously reported; however, I saved in park (right next to the transition to rooms), got seen, and loaded that save. It crashed on load. Attached:
(3.71 MiB) Downloaded 303 times
This video shows the entire process of producing that save and crash from the "turret_no_agro.zip" save uploaded previously. Additionally, about 30 seconds in, I manage to escape the elevator (or does the elevator escape me?):
► Show Spoiler