Page 1 of 1

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sun Apr 22, 2018 10:53 am
by Berathraben
I just had a crash at the hotel access entrance. It is probably not a new issue but thought it worth reporting. The game kept freezing and the hotel interior entrance door and exit doors would not open when I activated them. When I tried to open the doors before the crash it was also accompanied by the "voice" static.

Access violation - code c0000005 (first/second chance not available)

thetower!ACombatCharacter::DropWeapon() [c:\thetower\source\thetower\private\combatcharacter.cpp:2330]
thetower!AActor::GetFunctionCallspace() [d:\unrealengine_idgi\engine\source\runtime\engine\private\actor.cpp:3721]
thetower!UObject::execStructMemberContext() [d:\unrealengine_idgi\engine\source\runtime\coreuobject\private\uobject\scriptcore.cpp:2233]
thetower!ACombatCharacter::execDropWeapon() (recording from save reload after the crash) Cannot open exterior door now.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Fri May 04, 2018 5:03 pm
by FordGT90Concept
In Options, "Close" behaves the same as "Save & Apply." Additionally, Close/Save & Apply affect multiple tabs instead of just the one you're on:

Moving the sound sliders doesn't take immediate effect so you can hear the difference. You either have to restart the game or mute then unmute it to hear the difference.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat May 19, 2018 7:40 pm
by FordGT90Concept

The new combat balance, against turrets anyway, felt okay except for this spot just after Malcolm (might be another case of the random OP turret):

I managed to get back to the roof but it took me just shy of 15 minutes. If you think that's too long for someone that's familiar with the area, perhaps there needs to be stronger visual cues indicating how to leave.

Noticed the left slot above the PCU in the inventory doesn't show KAR AP rounds right:
I moved the stack to the right area and they show correctly. Move it back to the left slot and it appears how you see it (dark). I did not try putting anything else there, just the ammo. This was after getting stuff back from the Malcolm/Alvarez locker.

This has already been emailed to Steve but here it is again for posterity. There's a dialog that leads to a "yes, yes" conclusion instead of a "yes, no" conclusion:
The tree that starts with…
Elon Stone: Alright, enough chit-chat.

I did:
F2: What do you have that I need?
F1: Alright, I’m listening…
F3: AK-47s? That’s weird.
F1: Then you murdered those people at the docks.
F1: What do you want from me?
F1: If I say no?
F3: How can I trust you?
F3: And what kind of gear do you want?

And here’s the problem, there’s only three choices:
F1: Alright, I'll do it.
F2: My people say I shouldn't, but I'll do it.
F3: [Move On]

It’s missing a choice reflecting “No, I won’t give you illegally modified assault blasters.”

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat Jun 02, 2018 4:32 am
by FordGT90Concept
alphatest 1.5

Performance issues and pop-in issues running around the lobby exterior:

More to come...

Edit: ReLive quit recording audio at some point so...yeah...there isn't any...but none of them were audio bugs so it's okay...

Really bad pop out then pop in in the same area as the above video but that video didn't catch it. Luckily caught it later:

These stairs seem like they got shifted a bit so the rails block more of path than they should:

Rockets travel through walls to hit the Bishop:

This is right next to the rocket turret in the lobby (container draw distance should be a wee bit longer):

XO-1 Odin, he said he'd give me the key right at the top of the conversation. I ran away, later discovered I didn't have a key. I went back to him and talked to him because why not. I don't know if it's deliberate that he *intentionally* doesn't give you the keycard and you're supposed to press him for it or if this is just the result of being XO-1 conversation with him. Anyway, there's dialog that repeats here twice that is definitely a bug:

Bolt turrets still go OP:

First impression of water impeller physics was not good, ended up dying in this video:
This is immediately down the bath tub in Hotel Rooms.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat Jun 02, 2018 4:12 pm
by FordGT90Concept
alphatest 1.5

On combat balancing:
-consider reducing Odin's guys in Park and Rooms with five shields down to three.
-consider making kinetic rounds bypass shields completely that way you're not completely defenseless against armor damaging attacks.

There's fans that don't kill (but still trap) in the jail ducts:

Location indicators are in the foreground compared to the chat UI making it difficult to read dialog options: ... nknown.png

Friendly reminder that Famosa hacked CMC isn't using the CMC voice filter.

Odin subtitles, likely because of the squad mate interjecting, don't stay on screen long enough. Can't read what they're talking about before they disappear.

If you get the jump on Elon, his dialog struggles to trigger:

Will the real Elon please stand up? Please stand up. ... nknown.png

I may be crazy but I think the ducts leaving the jail area get a lot darker after the Malcolm encounter compared to before.

Malcolm isn't checking global conditions for XO-1. His dialog is the Consortium side right now. Should have tree specific to Voice side.

Probably specific to this alphatest version but twice I ended up jumping, ledge grabbing, and ending up above the jail area from inside the jail area.
Happened again in the Park -> Rooms transition room:

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sun Jun 03, 2018 3:29 am
by FordGT90Concept
Get stuck in the water treatment plant switch room area:

Lots of problems in the switch room/puzzle:
1) still can't distinguish the colors under water
1a) had a thought on that: why not make Tactical Hud remove the murkiness so you can clearly see the color?
2) so I swam up close to them on the right to try to get a better look at it, impeller pulled me in
3) I tried to swim away but it was no use
4) I swam through them, almost died trying but survived
5) Loaded save in switch room (because I cheesed the puzzle yet again), none of the impellers were spinning but they hurt to swim through

Water in the treatment plant water feels like it doesn't turn off gravity.

The talk anywhere with Frank not working only happens when XO-1'd.

The switches above Frank, Rook 9 said he marked one but none are marked.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Tue Jun 12, 2018 9:26 pm
by FordGT90Concept
alphatest 1.5 (were on Discord)

When you go to the jail via the ducts, the ducts are bright. When you reenter the ducts after interacting with Famosa, they darken: ... -07.17.mp4

Noticed a lot of convos missing, specifically, K15 related to talking to The Voice: ... nknown.png

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Fri Jun 15, 2018 7:22 pm
by FordGT90Concept
alphatest 1.5 (were on discord)

New game, from scratch, stealth incap, path: roof -> famosa -> roof -> hotel park by hoverpad -> hotel rooms by door -> water pipes -> hotel rooms -> TT core -> water treatment -> lobby

Random Thoughts:
-F8 is a weird key to press to save when it's contextual based. Why not make it the same as melee? Melee obviously isn't implemented yet but the bind can certainly handle dual purpose.
-Roof could use more save locations. I feel like King Kong scaling towers to save instead of swat at planes.
-The two AI on the ring at the center of the roof courtyard make the courtyard much more difficult to sneak than any other part of the roof. Would perhaps be easier if they patrolled instead of standing at one point and rotating.
-There's a part in the Ellen dialog where the subtitles says "Darsie" but the VO says "boss"
-Subtitle text covers up the hacking/scanning progress bar.
-Consortium Famosa (CMC encounter), it's possible to get the line where Rook 9 says "best friends forever" twice.
-The electrified water in the park is was able to swim in, I think, via crouching. The water is so shallow, it should just force standing, no?
-I got the dialog trigger about the TT on the courtyard shouldn't be there. When I got close to the TT ceiling in the park, Rook 9 gave his "Remember that..." dialog twice.
-The shield upgrade from 1500 energy/second to 1490 energy/second to 1475 energy/second is hardly worth it.
-Conversation manager doesn't scroll. It indicated that I had 9 messages but it would not show more than 8.
-Powered jumping in ducts and going through the water pipes is pretty much an inevitiable Untouchable = false situation.
-I believe water impellers are still too grabby receiving at least 256,500 energy worth of impeller damage (water treatment plant -> hotel lobby via pipes).
-Would be nice if there was a better visual que in TacHUD to indicate which way the bots are facing. Their feet are kind of unreliable.
-The hotel park feels like it doesn't have enough utility energy for how many guards and turrets are around there.
-KAR sniper mode should perhaps consume 2-4 ammo per shot to balance the high damage it does.

Previously reported:
-"Somebody Spoke to me" convo doesn't have the R25 follow up and never goes away.
-Roof yellow transponder elevator, can't just run out of it:
-Doug is still getting marked by TacHUD and that marker lingers long after he is gone: ... nknown.png
-Ammo in Hotel Rooms keeps spawning more and more and more: ... nknown.png
-If you're in water then load a save. The water sound effect applied to everything remains.
-The blackness by the water pipes nanite fragment looks like a bug (seeing the void) and not a feature:

This video demonstrates two bugs:
► Show Spoiler
Here's my main save where Preban has no inventory (the above is a new game from scatch demonstrating it): ... (also note how much overlapping dialog is in here)

Edit: Odin Log
(158.59 KiB) Downloaded 847 times

Likely Random, One-Off Fluke:
► Show Spoiler

Bugs, bugs, and more bugs:
Get damaged just above the entrance to the duct maze:

Maybe should move this patrol waypoint a tiny bit away from the edge (down below VXY antenna connecting to adjacent tower--under the slide) so he doesn't fall down to the courtyard when tased: ... nknown.png

Smashable grate by solar panels might be misplaced: ... nknown.png

IDGI bar hides and the Open doesn't go with it. Open tab just hangs there:

Catwalk above hoverpad has collision issues:

This remains a mystery but the save point by the hoverpad was inaccessible for me until I came back later:

Floor missing. The ladder to my right there goes up to the save point, hole down to Voice is behind me: ... nknown.png

Think he may have already fixed this one but four dudes got stuck on the TT in the Park next to the shaft down to the Voice: ... nknown.png

Voice room, there's a gap in the floor: ... nknown.png

Lots of areas of the Park have grass but no texture underneath so you see the void: ... nknown.png

Guard ended up between floors in the park: ... nknown.png

When incapping the guy above^ (he was the last one). Two bugs presented:
1) The dialog that triggered references the Roof instead of Odin's guys.
2) "Sleep It Off: Norwegian Style" achievement was granted when all of Odin's guys in the Hotel Rooms and Hotel Lobby are still concious.

Hole in wall in hotel rooms where those four turrets are: ... nknown.png

Shock Absorber upgrades are not saved/loaded: I went to TTCore, opened the hatch to security hub, saw the tunnel, was all NOPE, turned around and walked away, but it's stuck like this now: ... nknown.png

The area below the office in the hotel lobby has streaming issues. Example:
Crack in the wall looking through the crack at the office save point: ... nknown.png

Saw two searching lasers stuck in mid air. This may be a consequence of Odin's people in the Hotel Rooms were searching for me but Odin's people in the Lobby were not: ... nknown.png

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat Jun 16, 2018 7:35 pm
by FordGT90Concept
Loaded up the previous save and finished it out...

Hotel Lobby Restaurant bathrooms on upper floor have a ceiling mesh missing: ... nknown.png

On the same side of the lobby as above on the opposite side of the lobby from the restaurant, there's an invisible planter as part of that big column in the middle: ... nknown.png

Now I went up to the roof and noticed the organic cable is very misplaced where it wraps around and goes into the elevator: ... nknown.png

At the bottom of the elevator, the duct that drops down into the floor ends up dropping into the void: ... nknown.png
Following the tunnel into the jail, the jail is all kinds of messed up with the trap doors missing (did not get that event in this play through) and the door where Malcolm comes in is missing but still has collision so can't go through.

From there, I navigated through the duct maze and got what should be 7/7 nanite fragment. I later discovered the game thinks I have 6. I think one of them didn't count towards the counter but because there's no way to look how many fragments I have without triggering the end game, it will be very difficult to know which one didn't count: ... nknown.png
Also: I discovered at least two IDGI-1 Tunnels in this play through (one actually triggered the "universe log") yet the count is at 0.
Also: Also: Time cloaked over 6 hours? Impossible!

The Retro News story about Luna has "these question" when it should be "these questions."

FFS 2->4 nodes costs 350 gears. 4->6 nodes costs 40 gears. I think it's backwards. Or 40 was meant to be much higher?

End of traitor dialog, K15 says "alright, bishop has a job to do." Immediately after that, subtitles show R25 with a blank line.

Here's a list of all the convos I've done at least once that won't clear: ... nknown.png

Phased through a pipe here:

Rook 9 says he marked the switch to turn off power but it doesn't actually get marked. I ended up pushing all the switches instead: ... nknown.png

Swimming from that room back to the giant water pipe loop. The downward pressure of the water was *very* strong. As I was swimming towards that T junction, I was going directly at the impeller and fell down through the pipe before reaching the perpendicular pipe. I wasn't recording when it happened. Repro instructions:
1) go to power switch room normally
2) try to swim back to the big loop leaving the room
3) when you see the first impeller, swim along the bottom of the pipe
4) fall through the pipe before reaching the perpendicular pipe

NoClip doesn't work in water. I had no way to get back.

EA Alpha 1 4 bugs comments suggestions

Posted: Thu Aug 08, 2019 2:14 pm
by Kamroarl
Im really curious why some old, early reported and already fixed bugs from previous alpha versions return in new builds so often? Is it some difficulties in code sync between 3 devs?