Page 1 of 1

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Mon Jan 15, 2018 3:41 pm
by FordGT90Concept
Odds & Ends

Alignments
-Comparison of CG1 versus CG2 with import:
Image
1) John and Yanko shouldn't have -3 on import.
2) I don't really see the sense in importing characters that are dead.
3) Alignment only shows two characters. If -10, it only shows -.
-When I got XO-1'd, I saw Kiril get +15 or something like that. Kiril is dead. It would be nice if the function that handles alignment changes verifies they're alive before doing it.

Conversation Manager
-Conversations that aren't clearing
--What happened?
--Freefall Suit (might be because it got cut off and resumed, didn't clear after finishing resumed)
--Dr David Schelter

Bots
-They like to congregate which makes them prime targets for grenades. A single shot from a stock KAR is enough to cause this behavior. Perhaps the difference between "loud" and "soft" is too great? These are the only two maps I've seen it happen on:
--Hotel Park: https://youtu.be/1dskbCtKvns
--Hotel Interior: https://youtu.be/hflnZoVwAnw
-A lot of Odin's crew seem to have a Strommon rifle + ammo in addition to their KAR/Combat Shotgun. You'd think they'd only have their primary weapon. If they had a secondary, it would be like a pistol or something.
-I have yet to see one surrender/run in fear even with 93 of their comrades dead and way upgraded equipment so they couldn't possibly kill me. The morale system should perhaps be tweaked to make fear/surrender more common.
-When you snipe them from a long ways away, they instantly know exactly where you are. There should try to run for cover first, then a period of where they're trying to figure out where you are (calculated based on your concealment), then they should engage.
-Odin still has no inventory:
--no shields
--no weapon
--no ammo
--no Red Transponder key

Engineering System
-I think the increase in requirements for engineering points are okay so long as the upgrades we see are the same ones going to the end of the game (or at least well into Act 2).
-RE:energy requirements for engineering system: I'm mixed on this point because one can easily balance the collection of points with the high consumption rate of the Tactical HUD. If you don't use the Tactical HUD, however, the energy requirements seem way too low. What makes the most sense to me is simply removing energy from the engineering system altogether. The amount of energy is generally trivial and the ability to upgrade is already tempered by the scarcity of engineering points.
-BUS was the first thing I got fully upgraded and...it made me sad. A void was created by not having armor upgrades for it anymore. That or the other upgrades are too cheap (especially the taser ones) so it's easy to get to the end.

Weapons
-Shotgun:
--Useless against shields.
--Cooldown mechanic makes it dangerous to use against shielded enemies.
--The fact it doesn't cooldown itself over time is kind of silly.
--It may be overpowered against Elon's squad but it's mostly worthless (and great way to get killed) against Odin's squad.
--Can kill turrets hidding in the ground.
-KAR should have three behaviors:
--Unzoomed: full auto (unchanged damage)
--2x should be changed to 1.25x or 1.5x and fire 3-round bursts (same damage per shot as full auto).
--3.5x should be changed to 6x or 8x and fire the single shot sniper round (damage unchanged from what it is now).
-KAR upgrade that trades energy generation for dampening needs explanation of what's going on. I mean, why would a gun generate energy? Because recycling casings. Makes sense, but doesn't say that anywhere.
-KAR (and other items with long descriptions in inventory) has an auto-scrolling feature that's annoying on PC. Something like that may have to be done for the console version though. Actually, the whole inventory system may need to be rethought for controllers.

Miscellaneous
-Escape key didn't work during the XO-1 Voice conversation.
-I think I tried to put my shotgun away while it was streaming and the shotgun got stuck looking like this. Even if I dropped it and picked it up again, it kept glowing. Saving and loading fixed it but if memory serves, it caused a duplication bug (ended up with two partially upgraded shotguns in inventory):
► Show Spoiler
-Phased Matter Detector upgrade is available before encountering an Icer:
► Show Spoiler
-Achievement didn't trigger for killing 94 Odin squad members. Details on Google Doc.


Localized Stuff

Intro
-Environmental light is pulsing too regularly (visible on arms). It gives the impression I'm spinning. I quit listening to K15 because I was distracted by it: https://youtu.be/uYCoYOeNiy8

Hotel Park
-Can stuck in ground: https://youtu.be/tj8W1yINuhM
-Tablet stuck in floor, I got stuck in wall: https://youtu.be/bicfN9GJ_qE
-Columns not tall enough: https://youtu.be/-X9AmsJiXx8
-Locked cabinet with unreachable bowls in it: https://youtu.be/1p5LXia_P58
-Geometry issues and level placed in wall: https://youtu.be/kbRleN_Qa2s
-Geometry gap into the void: https://youtu.be/HW-PCg5zrNs

Hotel Interior
-Slow streaming of lower floor via duct: https://youtu.be/JaNIPiyIXWI
-Lots of problems with cabinets with recycleables being locked or having mesh issues so you can't get to them (list is incomplete):
--https://youtu.be/0ls8nUb-ljc
--https://youtu.be/JDN9yWWJWCk

Hotel Lobby
-Pointing at a gap in this picture:
► Show Spoiler
-Performance and Streaming problems on top floor: https://youtu.be/FbiXXOtfAU0
-Two locations in the office where resources respawn...
--3 carbon crates and a light on the other side of the wall: https://youtu.be/nfHvWleyiOQ
--2 resource crates, pallet lift, and tablet: https://youtu.be/km83RBTVwik
-Leave world via duct: https://youtu.be/GTbTWB5V-So
-Potential gap and a door that should be locked: https://youtu.be/WYPAgkQaGiA
-Streaming issues and objects that can't be recycled (has voice over): https://youtu.be/--CBYJ5TjwQ
-Invisible objects...
--Dunno what that round thing is supposed to be on the floor either: https://youtu.be/Tc9YHBZr4Uo
--https://youtu.be/57t4n-aL6EE
-Recyclable objects placed in wall: https://youtu.be/o-z3vTG8pw4
-Streaming issues: https://youtu.be/BX6UAroqPDg
-Turret hides sticking it's bottom out on exterior (I think it's a rocket turret):
► Show Spoiler
Water Treatment Plant
-Had BUS and broken FFS (because XO-1), couldn't escape the water with the six blades on the bottom.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Tue Jan 16, 2018 3:30 am
by FordGT90Concept
I believe this is from the same save as the Janitor: Hotel Lobby save above:
https://youtu.be/fUHZGDnig_k
0:00 notice that the snow doesn't go away until I enter the corridor with all the red transponder elevators.
0:20 the red transponder elevator doesn't come. If it does eventually, I'm tired of waiting for it. On that note: the low velocity elevators to prevent player escape could probably be ignored when the player isn't in the elevator. Less waiting if it really is just moving that slow...
3:14 IDGI tunnel warning when there no longer is an IDGI tunnel here.
3:57 turbines aren't spinning but they still hurt...a little bit.
5:10 escape the tunnels into the wet void.



No video of this but the water hub is ridiculous. Specifically:
1) lack of save points
2) lack of recyclables
3) electrified floor with switches basically in it and no clear means to disable the electricity
4) many areas require use of the FFS which, good luck if you don't have energy (see #2)
5) FFS responds too forcefully to minor collisions
6) FFS not having jump work to go up when flying parallel to Earth make maintaining altitude and slowing decent needlessly complicated

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Tue Jan 16, 2018 1:52 pm
by GreatBird
Some really great posts above. A bunch of stuff is already on the list but lots of this is exactly what we're looking for, so thanks.

The WaterHub is very much supposed to be extremely deadly and difficult. It allows one to bypass things that otherwise require other types of gameplay (combat or diplomacy), so it's not designed to be "friendly" to players, at all. Going in with with upgrades and lots of energy is required. Also there are quite a few juicy recyclables but a lot of them are hidden.

That said, we hear the feedback regardless. You can expect more save spots and a few more hidden recyclables in the next update.

"3) electrified floor with switches basically in it and no clear means to disable the electricity" -- Yep, forcing you into the electricity to continue - if you don't have the energy or upgraded gear to handle it, it's time to backtrack!

"4) many areas require use of the FFS which, good luck if you don't have energy (see #2)" -- Actually other than fans that are too strong and trap you, there shouldn't be any areas that truly REQUIRE a FFS.... ?

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Tue Jan 16, 2018 3:28 pm
by omgalof
crash report time:
► Show Spoiler
trying to pass that hatch causes a crash, my way there was, go down tower 1 ventilation all the way to 212121 then go down to the lobby enter the waterways by the frozen pool's and go up to the vents around the cell.

crash report on attachments, also this hatch switch on the lobby don't work

https://youtu.be/A8bYLDX0gY4

edit: added the save file

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Tue Jan 16, 2018 9:31 pm
by FordGT90Concept
GreatBird wrote:
Tue Jan 16, 2018 1:52 pm
"3) electrified floor with switches basically in it and no clear means to disable the electricity" -- Yep, forcing you into the electricity to continue - if you don't have the energy or upgraded gear to handle it, it's time to backtrack!

"4) many areas require use of the FFS which, good luck if you don't have energy (see #2)" -- Actually other than fans that are too strong and trap you, there shouldn't be any areas that truly REQUIRE a FFS.... ?
They were both talking about the same room with electirifed floor and four switches. I don't think any of the switches are reachable without the FFS because there's columns abstructing all the paths horizontally. The two on the water line are also unreachable without using FFS either to stay out of the water, or to get out of the water. My FFS had two regular shields and I had less than 2-3 seconds to death. Even my fully upgraded BUS with 5 upgraded shields (all upgrades were costing 100+ EP at that point) lost 2-3 shields by the time I switched to the FFS and flew out of the water.

I think the damage of that water needs to be reduced or, at bare minimum, a save point right there so if you fail, you can try again. If the latter, it can still become a trial of patience.

Another suggestion is to allow the multiboost upgrade for the BUS to work in water.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Wed Jan 17, 2018 10:25 pm
by GreatBird
All of the switches can be reached with super jumping and ledge grabbing. It's true that the two in the water are tricky because of the water and turrets. You don't need the FFS to get out of the water, though - you can ledge grab out of it with the center platform.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Thu Jan 18, 2018 4:58 pm
by FordGT90Concept
Isolated bRegistered.
https://youtu.be/qYUOhv-jiuw

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Fri Jan 19, 2018 4:30 pm
by FordGT90Concept
Was going between roof and park over and over for 10 minutes. Alt+tabbed out for a minute. The recording has everything after I tabbed back into the game.
https://youtu.be/jpG_ohFGY9k

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat Jan 20, 2018 5:19 am
by FordGT90Concept
Two videos from alphatest. In both cases, NextBot.SeePlayer 0

First video I simply fell out of the world (again). All benches moved freely:
https://youtu.be/qhuwtzFdFgc

Second video, I pushed around a bunch of benches and tried to make it crash via roof door. Failing that, I went back inside and was caught off guard that some of the benches were locked again. That's when I noticed all the save sphere spam in the console. For some reason, the benches unlocked again so I went cow bench tipping for a while. I tried the roof streaming door and it didn't crash. I tried the interior door and it did crash. Typical Rama K2Node crash again.
https://youtu.be/00-E1HHdPvU

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Mon Jan 22, 2018 9:38 pm
by FordGT90Concept
bRegistered on the latest alphatest (has debugging info in video):
https://youtu.be/0ymxt7e8hSI

Just before the crash, the screen says:

Code: Select all

ABOUT TO STREAM B--E_HotelTowers_1_2_4_Park
OMEGA Attempting to load B--E_HotelTowers_1_2_4_Park
Adding B--E_HotelTowers_1_2_4_Park to currently loaded levels
Starting for each loop
Setting streaming levels array
Delay .2 End Buffering Stream Indicator
Delay .2 Start
DISABLE SAVE SPHERES
Then it purged all of them except the "OMEGA" line to the crash.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Tue Jan 30, 2018 12:56 pm
by omgalof
bug: upon placing the items Elon requested on the box(the ones you get from Preben Cache) the quest competition do not trigger


edit: save added

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sun Feb 04, 2018 1:31 am
by BlueShiftRecall
"Turning the Tables - Speak to the Consortium Traitor" randomly achieved for me today when I spoke with the "traitor." It was never achieved in previous games but today for some reason it worked? No idea why since I read it was bugged.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat Feb 10, 2018 9:47 pm
by FordGT90Concept
Discord feedback on mechanics:
Manic wrote:turrets instantly damaging you instead of a wind up or warning of any kind, combat is currently stand and shoot, charge jump needs a lot of work, along with the freefall suit being near useless to even go 10 meters down at a 45 degree angle

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Wed Feb 14, 2018 3:10 pm
by GreatBird
BlueShift: It WAS bugged but is fixed now in alphatest.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Fri Mar 23, 2018 3:54 am
by piolin
Game crashes while loading a save, ue4 crash window displays the following:

Access violation - code c0000005 (first/second chance not available)

thetower!ACombatCharacter::DropWeapon() [c:\thetower\source\thetower\private\combatcharacter.cpp:2330]
thetower!AActor::GetFunctionCallspace() [d:\unrealengine_idgi\engine\source\runtime\engine\private\actor.cpp:3721]
thetower!UObject::execStructMemberContext() [d:\unrealengine_idgi\engine\source\runtime\coreuobject\private\uobject\scriptcore.cpp:2233]
thetower!ACombatCharacter::execDropWeapon()

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Fri Mar 30, 2018 2:37 am
by FordGT90Concept
Had a player experience this upon using the Steam Overlay. It may be related to ResolutionQuality being out of bounds (like -998). I tried to replicate this myself and it failed to reproduce (got pixelated, not a box inside of a box as shown):
► Show Spoiler
Same user also entered combat faster than expected, likely because agitation rises too fast (as in jumps from 5 to 9). I think the randomness of the jump is a bad thing. It should just rise incrementally and open fire at 9. The randomness presents as a bug even though it isn't. Two more suggestions here:
1) Make aggitation "jump" up if you startle them (e.g. you're less than 10' away when they notice you).
2) If you're going to keep the randomness, how about having a pull of VO lines to pull from that signify the next will be a fire fight. For example, they could say "trigger finger getting itchy" or "stop skulking around Bishop!"


There really needs to be a quicksave or something after Malcolm is done talking because the conversations between the save point and the surprise fight are so long and the failure rate of that fight is high. Additionally, the game should check for and auto equip:
1) If BUS is fully repaired, equip it.
2) If shields are fully repaired, equip them in the BUS if they aren't already
3) If Assault Rifle is fully repaired, equip it.
4) If Combat Shotgun is fully repaired, equip it instead of the AR.
That way, without even thinking, you're better prepared to deal with what is about to hit. You could even do a little IDGI signal loss while this is happening and throw something in the IDGI box at the top saying "Player Assistance Executed" or something.


Player wasn't sure how to use grenades. I told him he needs KAR. He says he's screwed (not enough energy to repair it) because he doesn't have energy, ammo, or guns to survive after escaping Malcolm.



I've not noticed any bullets penetrate anything they're not supposed to. Might be able to speed up velocity a bit more.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Fri Mar 30, 2018 6:38 pm
by FordGT90Concept
Requested 5 most annoying things about the water hub:

1) Swimming perpendicular to a fan and getting sucked to your death. Solution: use exponential force on the sucking. It's only inescapable if you're right next to it.
Image

2) Electrified water that kills almost instantly (that whole room in general is awful). If you don't have the FFS and a lot of energy, it isn't even worth trying. Solution: reduce the damage of the electricity to next to nothing or add a switch to disable it in the room somewhere.

3) The duct maze is good on the roof because you can use the automap and some logic to eliminate routes. That doesn't work with the waterhub maze. Solution: Allow the automap to work in the "Unknown Interference" area.

4) Can't tell if a fan is sucking or blowing looking directly at it. Solution: make them glow red on the sucking side and green on the exhaust side. If glowing is too costly, color the blades to indicate sucking and blowing sides.

5) Not enough save spheres. Every time I died, I had to cover a lot of distance to get back to where I was. Solution: add more save spheres.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Fri Mar 30, 2018 10:07 pm
by FordGT90Concept
This one isn't a bug but just showing how:
a) 3.5x isn't enough zoom.
b) no gravity so sniping like this is super easy.
c) time between shot and impact.
https://youtu.be/n4Welyx-Y6E

I accidentally rolled the wheel instead of clicking it (to change zoom). The important thing to note here is that, in the thick of combat, how difficult it is to get the KAR reselected for many reasons:
a) weapons aren't automatically equipped when the wheel is rolled, only selected.
b) other crap is in the bar including armor and stealth nodes.
c) which item is highlighted doesn't stand out from the rest.
https://youtu.be/D_8XI1NXnSk

I think AI should auto-detect player if within 1m. When something is in feeling distance, it's nigh impossible to stay hidden. Stealth node could/should break that rule.
https://youtu.be/YZstVPH80iY

This isn't the only place I've seen this behavior but here's an example.
https://youtu.be/7Z-FY3l0jvc

I feel like a midget at the end of the elevator ride because the crouch/stand height is so low to the floor. It fixes itself on disembarking but, awkward.
https://youtu.be/roetgnHO3ro

Having a gun out completely changes how FFS works. Apparently the axis are fixed to the same as standing; however, I run into the same issue as FFS in general: the platform I need to get to is just above me and I can't get there because pushing jump means turning the FFS off. So I decide to put it away and then the next bug presents itself. The KAR is glowy and when I try to put it away, it's automatically pulling the CEAR out. When I try to put the CEAR away, it automatically gets the KAR out. I eventually look at my inventory to see that *neither* are equipped. So I recycle the CEAR and it doesn't fix anything. Also try manually equipping and unequipping the KAR. Nothing works. I ended up loading a save...all because I can't fly up a few feet.
https://youtu.be/Pi6IobWr4Oo

https://youtu.be/OvOjzBt0n4s

I really don't know how you're going to fix this one...
https://youtu.be/anhCqQ1E9SQ

...easier to just ignore the puzzle and go on through.
https://youtu.be/lVsZ2muvL94

https://youtu.be/rdnGfNE_cxA

https://youtu.be/f-5WU9aKkAM

Pretty sure I reported getting stuck here before. It's between those water tanks in the water hub and the hotel lobby.
https://youtu.be/d6rEuffimvg


There's a piece of pipe that isn't rendering in the Automap circled in red:
► Show Spoiler

I found the place to get that achievement why I set off on this in the first place and..."talk anywhere" is broken. That or I pushed the wrong key, but I doubt it. Trying again now...

Edit: I was told that this is probably caused by alt+tab, which I did, to stop music that was playing so I could hear him talk. Apparently I needed to left click to fix "talk anywhere" but I didn't want to do that for fear of making him attack me. Seems plausible that alt+tab broke it.

Edit: Checked my "talk" bind it matches the key I'm pushing. It isn't working on a second attempt. All that work for more bugs. :cry:

Also, it's really difficult, if not impossible, to get out of the water in this area. 2/2 I had to equip the FFS and fly out.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat Mar 31, 2018 2:15 pm
by FordGT90Concept
Requested video + save of Frank.
https://youtu.be/-hj4LoZXrjs

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat Mar 31, 2018 9:19 pm
by FordGT90Concept

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sun Apr 22, 2018 10:53 am
by Berathraben
I just had a crash at the hotel access entrance. It is probably not a new issue but thought it worth reporting. The game kept freezing and the hotel interior entrance door and exit doors would not open when I activated them. When I tried to open the doors before the crash it was also accompanied by the "voice" static.



Access violation - code c0000005 (first/second chance not available)

thetower!ACombatCharacter::DropWeapon() [c:\thetower\source\thetower\private\combatcharacter.cpp:2330]
thetower!AActor::GetFunctionCallspace() [d:\unrealengine_idgi\engine\source\runtime\engine\private\actor.cpp:3721]
thetower!UObject::execStructMemberContext() [d:\unrealengine_idgi\engine\source\runtime\coreuobject\private\uobject\scriptcore.cpp:2233]
thetower!ACombatCharacter::execDropWeapon()

https://youtu.be/rIEToskEdWg (recording from save reload after the crash) Cannot open exterior door now.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Fri May 04, 2018 5:03 pm
by FordGT90Concept
In Options, "Close" behaves the same as "Save & Apply." Additionally, Close/Save & Apply affect multiple tabs instead of just the one you're on:
https://www.youtube.com/watch?v=kH_wqz7lavI


Moving the sound sliders doesn't take immediate effect so you can hear the difference. You either have to restart the game or mute then unmute it to hear the difference.
https://www.youtube.com/watch?v=i95xftpjSg4
https://youtu.be/3QnwpDkh8VA

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat May 19, 2018 7:40 pm
by FordGT90Concept
alphatest

The new combat balance, against turrets anyway, felt okay except for this spot just after Malcolm (might be another case of the random OP turret):
https://youtu.be/J4qg2YIyNQw

I managed to get back to the roof but it took me just shy of 15 minutes. If you think that's too long for someone that's familiar with the area, perhaps there needs to be stronger visual cues indicating how to leave.

Noticed the left slot above the PCU in the inventory doesn't show KAR AP rounds right:
Image
I moved the stack to the right area and they show correctly. Move it back to the left slot and it appears how you see it (dark). I did not try putting anything else there, just the ammo. This was after getting stuff back from the Malcolm/Alvarez locker.

This has already been emailed to Steve but here it is again for posterity. There's a dialog that leads to a "yes, yes" conclusion instead of a "yes, no" conclusion:
The tree that starts with…
Elon Stone: Alright, enough chit-chat.

I did:
F2: What do you have that I need?
F1: Alright, I’m listening…
F3: AK-47s? That’s weird.
F1: Then you murdered those people at the docks.
F1: What do you want from me?
F1: If I say no?
F3: How can I trust you?
F3: And what kind of gear do you want?

And here’s the problem, there’s only three choices:
F1: Alright, I'll do it.
F2: My people say I shouldn't, but I'll do it.
F3: [Move On]

It’s missing a choice reflecting “No, I won’t give you illegally modified assault blasters.”

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat Jun 02, 2018 4:32 am
by FordGT90Concept
alphatest 1.5

Performance issues and pop-in issues running around the lobby exterior:
https://youtu.be/x4moqTuENLA

More to come...

Edit: ReLive quit recording audio at some point so...yeah...there isn't any...but none of them were audio bugs so it's okay...

Really bad pop out then pop in in the same area as the above video but that video didn't catch it. Luckily caught it later:
https://youtu.be/7aKxWgUv7xA

These stairs seem like they got shifted a bit so the rails block more of path than they should:
https://youtu.be/UxtpwllhZYw

Rockets travel through walls to hit the Bishop:
https://youtu.be/nHobOc4CpRs

This is right next to the rocket turret in the lobby (container draw distance should be a wee bit longer):
https://youtu.be/cLSrvSm0rpw

XO-1 Odin, he said he'd give me the key right at the top of the conversation. I ran away, later discovered I didn't have a key. I went back to him and talked to him because why not. I don't know if it's deliberate that he *intentionally* doesn't give you the keycard and you're supposed to press him for it or if this is just the result of being XO-1 conversation with him. Anyway, there's dialog that repeats here twice that is definitely a bug:
https://youtu.be/hiMyHkzlK1w

Bolt turrets still go OP:
https://youtu.be/wWz5G_RXk5I

First impression of water impeller physics was not good, ended up dying in this video:
https://youtu.be/iDQ9BKdfTA8
This is immediately down the bath tub in Hotel Rooms.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat Jun 02, 2018 4:12 pm
by FordGT90Concept
alphatest 1.5


On combat balancing:
-consider reducing Odin's guys in Park and Rooms with five shields down to three.
-consider making kinetic rounds bypass shields completely that way you're not completely defenseless against armor damaging attacks.

There's fans that don't kill (but still trap) in the jail ducts:
https://youtu.be/plN__wfbEWE

Location indicators are in the foreground compared to the chat UI making it difficult to read dialog options:
https://cdn.discordapp.com/attachments/ ... nknown.png

Friendly reminder that Famosa hacked CMC isn't using the CMC voice filter.

Odin subtitles, likely because of the squad mate interjecting, don't stay on screen long enough. Can't read what they're talking about before they disappear.

If you get the jump on Elon, his dialog struggles to trigger:
https://youtu.be/eplALFjNzFg
https://youtu.be/_KZzA1GDhPc

Will the real Elon please stand up? Please stand up.
https://cdn.discordapp.com/attachments/ ... nknown.png

I may be crazy but I think the ducts leaving the jail area get a lot darker after the Malcolm encounter compared to before.

Malcolm isn't checking global conditions for XO-1. His dialog is the Consortium side right now. Should have tree specific to Voice side.


Probably specific to this alphatest version but twice I ended up jumping, ledge grabbing, and ending up above the jail area from inside the jail area.
https://youtu.be/hOTCcIt3rZI
Happened again in the Park -> Rooms transition room:
https://youtu.be/UBc8BK7QBtc

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sun Jun 03, 2018 3:29 am
by FordGT90Concept
Get stuck in the water treatment plant switch room area:
https://youtu.be/hM3d3076hME

Lots of problems in the switch room/puzzle:
1) still can't distinguish the colors under water
1a) had a thought on that: why not make Tactical Hud remove the murkiness so you can clearly see the color?
2) so I swam up close to them on the right to try to get a better look at it, impeller pulled me in
3) I tried to swim away but it was no use
4) I swam through them, almost died trying but survived
5) Loaded save in switch room (because I cheesed the puzzle yet again), none of the impellers were spinning but they hurt to swim through


Water in the treatment plant water feels like it doesn't turn off gravity.


The talk anywhere with Frank not working only happens when XO-1'd.

The switches above Frank, Rook 9 said he marked one but none are marked.

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Tue Jun 12, 2018 9:26 pm
by FordGT90Concept
alphatest 1.5 (were on Discord)

When you go to the jail via the ducts, the ducts are bright. When you reenter the ducts after interacting with Famosa, they darken:
https://cdn.discordapp.com/attachments/ ... -07.17.mp4

Noticed a lot of convos missing, specifically, K15 related to talking to The Voice:
https://cdn.discordapp.com/attachments/ ... nknown.png

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Fri Jun 15, 2018 7:22 pm
by FordGT90Concept
alphatest 1.5 (were on discord)

New game, from scratch, stealth incap, path: roof -> famosa -> roof -> hotel park by hoverpad -> hotel rooms by door -> water pipes -> hotel rooms -> TT core -> water treatment -> lobby

Random Thoughts:
-F8 is a weird key to press to save when it's contextual based. Why not make it the same as melee? Melee obviously isn't implemented yet but the bind can certainly handle dual purpose.
-Roof could use more save locations. I feel like King Kong scaling towers to save instead of swat at planes.
-The two AI on the ring at the center of the roof courtyard make the courtyard much more difficult to sneak than any other part of the roof. Would perhaps be easier if they patrolled instead of standing at one point and rotating.
-There's a part in the Ellen dialog where the subtitles says "Darsie" but the VO says "boss"
-Subtitle text covers up the hacking/scanning progress bar.
-Consortium Famosa (CMC encounter), it's possible to get the line where Rook 9 says "best friends forever" twice.
-The electrified water in the park is was able to swim in, I think, via crouching. The water is so shallow, it should just force standing, no?
-I got the dialog trigger about the TT on the courtyard shouldn't be there. When I got close to the TT ceiling in the park, Rook 9 gave his "Remember that..." dialog twice.
-The shield upgrade from 1500 energy/second to 1490 energy/second to 1475 energy/second is hardly worth it.
-Conversation manager doesn't scroll. It indicated that I had 9 messages but it would not show more than 8.
-Powered jumping in ducts and going through the water pipes is pretty much an inevitiable Untouchable = false situation.
-I believe water impellers are still too grabby receiving at least 256,500 energy worth of impeller damage (water treatment plant -> hotel lobby via pipes).
-Would be nice if there was a better visual que in TacHUD to indicate which way the bots are facing. Their feet are kind of unreliable.
-The hotel park feels like it doesn't have enough utility energy for how many guards and turrets are around there.
-KAR sniper mode should perhaps consume 2-4 ammo per shot to balance the high damage it does.

Previously reported:
-"Somebody Spoke to me" convo doesn't have the R25 follow up and never goes away.
-Roof yellow transponder elevator, can't just run out of it: https://youtu.be/vSN9OySjiI4
-Doug is still getting marked by TacHUD and that marker lingers long after he is gone: https://cdn.discordapp.com/attachments/ ... nknown.png
-Ammo in Hotel Rooms keeps spawning more and more and more: https://cdn.discordapp.com/attachments/ ... nknown.png
-If you're in water then load a save. The water sound effect applied to everything remains.
-The blackness by the water pipes nanite fragment looks like a bug (seeing the void) and not a feature: https://youtu.be/CgR91ojxOzo

This video demonstrates two bugs:
► Show Spoiler
Here's my main save where Preban has no inventory (the above is a new game from scatch demonstrating it):
https://cdn.discordapp.com/attachments/ ... _empty.zip
https://youtu.be/FVERzv-Hs2I (also note how much overlapping dialog is in here)

Edit: Odin Log
odin_log.zip
(158.59 KiB) Downloaded 44 times

Likely Random, One-Off Fluke:
► Show Spoiler

Bugs, bugs, and more bugs:
Get damaged just above the entrance to the duct maze:
https://youtu.be/mZyoHXcwuog

Maybe should move this patrol waypoint a tiny bit away from the edge (down below VXY antenna connecting to adjacent tower--under the slide) so he doesn't fall down to the courtyard when tased:
https://cdn.discordapp.com/attachments/ ... nknown.png

Smashable grate by solar panels might be misplaced:
https://cdn.discordapp.com/attachments/ ... nknown.png

IDGI bar hides and the Open doesn't go with it. Open tab just hangs there:
https://youtu.be/v8ycojnWr_0

Catwalk above hoverpad has collision issues:
https://youtu.be/sqTQWuDD3q4

This remains a mystery but the save point by the hoverpad was inaccessible for me until I came back later:
https://youtu.be/pvv5vWsEuFc

Floor missing. The ladder to my right there goes up to the save point, hole down to Voice is behind me:
https://cdn.discordapp.com/attachments/ ... nknown.png

Think he may have already fixed this one but four dudes got stuck on the TT in the Park next to the shaft down to the Voice:
https://cdn.discordapp.com/attachments/ ... nknown.png

Voice room, there's a gap in the floor:
https://cdn.discordapp.com/attachments/ ... nknown.png

Lots of areas of the Park have grass but no texture underneath so you see the void:
https://cdn.discordapp.com/attachments/ ... nknown.png

Guard ended up between floors in the park:
https://cdn.discordapp.com/attachments/ ... nknown.png
https://youtu.be/CeiWIv-qNok

When incapping the guy above^ (he was the last one). Two bugs presented:
1) The dialog that triggered references the Roof instead of Odin's guys.
2) "Sleep It Off: Norwegian Style" achievement was granted when all of Odin's guys in the Hotel Rooms and Hotel Lobby are still concious.

Hole in wall in hotel rooms where those four turrets are:
https://cdn.discordapp.com/attachments/ ... nknown.png

Shock Absorber upgrades are not saved/loaded: I went to TTCore, opened the hatch to security hub, saw the tunnel, was all NOPE, turned around and walked away, but it's stuck like this now:
https://cdn.discordapp.com/attachments/ ... nknown.png

The area below the office in the hotel lobby has streaming issues. Example:
https://youtu.be/Uk_lJ4yktOg
Crack in the wall looking through the crack at the office save point:
https://cdn.discordapp.com/attachments/ ... nknown.png

Saw two searching lasers stuck in mid air. This may be a consequence of Odin's people in the Hotel Rooms were searching for me but Odin's people in the Lobby were not:
https://cdn.discordapp.com/attachments/ ... nknown.png

Re: EA Alpha 1.4 bugs, comments, suggestions!

Posted: Sat Jun 16, 2018 7:35 pm
by FordGT90Concept
Loaded up the previous save and finished it out...


Hotel Lobby Restaurant bathrooms on upper floor have a ceiling mesh missing:
https://cdn.discordapp.com/attachments/ ... nknown.png

On the same side of the lobby as above on the opposite side of the lobby from the restaurant, there's an invisible planter as part of that big column in the middle:
https://cdn.discordapp.com/attachments/ ... nknown.png


Now I went up to the roof and noticed the organic cable is very misplaced where it wraps around and goes into the elevator:
https://cdn.discordapp.com/attachments/ ... nknown.png

At the bottom of the elevator, the duct that drops down into the floor ends up dropping into the void:
https://cdn.discordapp.com/attachments/ ... nknown.png
Following the tunnel into the jail, the jail is all kinds of messed up with the trap doors missing (did not get that event in this play through) and the door where Malcolm comes in is missing but still has collision so can't go through.


From there, I navigated through the duct maze and got what should be 7/7 nanite fragment. I later discovered the game thinks I have 6. I think one of them didn't count towards the counter but because there's no way to look how many fragments I have without triggering the end game, it will be very difficult to know which one didn't count:
https://cdn.discordapp.com/attachments/ ... nknown.png
Also: I discovered at least two IDGI-1 Tunnels in this play through (one actually triggered the "universe log") yet the count is at 0.
Also: Also: Time cloaked over 6 hours? Impossible!


The Retro News story about Luna has "these question" when it should be "these questions."


FFS 2->4 nodes costs 350 gears. 4->6 nodes costs 40 gears. I think it's backwards. Or 40 was meant to be much higher?


End of traitor dialog, K15 says "alright, bishop has a job to do." Immediately after that, subtitles show R25 with a blank line.

Here's a list of all the convos I've done at least once that won't clear:
https://cdn.discordapp.com/attachments/ ... nknown.png


Phased through a pipe here:
https://youtu.be/202vxCDjTnI


Rook 9 says he marked the switch to turn off power but it doesn't actually get marked. I ended up pushing all the switches instead:
https://cdn.discordapp.com/attachments/ ... nknown.png


Swimming from that room back to the giant water pipe loop. The downward pressure of the water was *very* strong. As I was swimming towards that T junction, I was going directly at the impeller and fell down through the pipe before reaching the perpendicular pipe. I wasn't recording when it happened. Repro instructions:
1) go to power switch room normally
2) try to swim back to the big loop leaving the room
3) when you see the first impeller, swim along the bottom of the pipe
4) fall through the pipe before reaching the perpendicular pipe

NoClip doesn't work in water. I had no way to get back.

EA Alpha 1 4 bugs comments suggestions

Posted: Thu Aug 08, 2019 2:14 pm
by Kamroarl
Im really curious why some old, early reported and already fixed bugs from previous alpha versions return in new builds so often? Is it some difficulties in code sync between 3 devs?