Page 2 of 2

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Mon Dec 04, 2017 3:31 am
by Berathraben
FordGT90Concept wrote:
Thu Nov 23, 2017 6:44 pm
This video shows three things:
1) The graphic settings I had it set to.
2) The poor performance on the rooftop. Could be related to running 17.11.3, needs confirmation.
3) Hitting escape with graphic settings open doesn't close graphic settings.
https://youtu.be/LuFfDcrTirI

Nov 24 Edit: Performance drop between 17.7 and 17.11.2 drivers. May be fixed in 17.11.3...

The massive framerate issues I saw in the video above are definitely caused by enabling vsync in the game. With vsync off, the framerate weirdly never exceeds 62 fps.
I tried to duplicate the FPS issues Ford had. I updated to 17.11.1 and have a AMD R9 380 GPU. I did not have any of the same issues at least as far as I could tell.

https://youtu.be/Mf-UgsFqQb0

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Mon Dec 04, 2017 4:01 am
by Berathraben
I have recently encountered a few bugs

They are on the floor when you use the Yellow key card from Elon to take the elevator (16X floor).
The Tower (64-bit, PCD3D_SM5) 12_4_2017 2_37_53 AM.png
The Tower (64-bit, PCD3D_SM5) 12_4_2017 2_37_53 AM.png (2.28 MiB) Viewed 1656 times


The first potential bug is hitting an invisible wall. This particular one could be intentional...but there appears to be an empty space behind it.
The Tower (64-bit, PCD3D_SM5) 12_4_2017 1_41_36 AM.png
The Tower (64-bit, PCD3D_SM5) 12_4_2017 1_41_36 AM.png (1.25 MiB) Viewed 1656 times
I cannot move passed this spot but it looks like there is an opening. It feels like I am hitting an invisible wall.
The Tower (64-bit, PCD3D_SM5) 12_4_2017 1_44_32 AM.png
The Tower (64-bit, PCD3D_SM5) 12_4_2017 1_44_32 AM.png (919.49 KiB) Viewed 1656 times
This is the door leading to that room.

The second bug is the floor and walls disappearing and I end up falling through the floor. There are also grenade packs hidden in the area and they respawn every time I drop thorough the floor.

https://youtu.be/99F_BVfCYbQ

The Third bug is when I recycle a table some times the objects on top start bouncing on the floor or disappear altogether. I only have a video of the former.

https://youtu.be/a9ADemD8rsY

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Tue Dec 05, 2017 12:47 pm
by DevourMistress
just letting you guys know, if you don't already know, that hotel floors 169, 170 and 171 are having issues with environment loading. walls, the floor and the ceiling glitching, sometimes even disappearing [which means turrets aim at you through walls, but the collisions are still there so they can't do anything]. Oh, and the floor 170 has floor issues in front of elevators: it means that the floors in front of elevators don't load at all: no collision, no textures. You can wall through them to floor below if you're not careful.

Edit: forgot to mention, that when climbing in the vents or higher areas in floor 170, the floor can glitch and make you wall to floor below. Texture/collisions unloading, then reloading

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Tue Dec 05, 2017 1:33 pm
by DevourMistress
Image
Image

issue on vent floor collision/texture. automap location below it. Already reported and pic linked on discord, simply record keeping by officially posting here too

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Tue Dec 05, 2017 2:16 pm
by DevourMistress
found an interesting vent bug on floor 171

https://www.youtube.com/watch?v=AXk6V4JUc2Y

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Wed Dec 13, 2017 10:42 pm
by FordGT90Concept
12/13 achievementtest

-vsync still pulses on my R9 390. I get about 30-45 fps with it enabled and 45-60 fps with it disabled. My monitor is 60 Hz.

-VO volume still doesn't fall off appropriately. Their lines sound about as loud 30 feet away as they do 3 feet away.

Major/Game Breaking Bugs!
1. Automap is broken.
https://youtu.be/Oh3azKdm38Q
2. No Voice lines about meeting him.
3. No objective to open Automap and mark 212121 location.
4. Voice encounter does not trigger.
https://youtu.be/lrDMdCmkCHY

-Recycled Elon's Transponder by accident. I hope it is made so just interaction with Elon's body is enough to claim it so doing "recycle all" on Elon doesn't screw you out of that transponder.

-"What happened" conversation is no longer available to players that captured the traitor (because cannon story doesn't capture the traitor) so there is no dialog chain, as far as I'm aware, that leads to a conversation with the traitor. ACHIEVEMENT_TRAITOR_CONVO is therefore impossible.

-Ellen subtitle says: "...experiment Darise cooked up..." the VO says "...experiment the boss cooked up..." Directly following that, Seeker: "And Darise, that's your boss?" doesn't make sense because she says "the boss" not "Darsie." That selection should be something like "And who is your boss?" Ellen already starts that response with "Darsie Lensworth" TL;DR: what it should be...
Ellen subtitle: "...experiment the boss cooked up..."
Seeker response: "And who is your boss?"
Ellen response: "Darsie Lensworth."

https://youtu.be/0gv_JI46CjY

https://youtu.be/hJH9dbdEdTo

https://youtu.be/vEWGyAbl6Ts

https://youtu.be/9sB7NdzwkoM

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Fri Dec 15, 2017 5:03 am
by DevourMistress
Another missing textures/collision (note, also automap for some reason didn't show player icon)

Image
Image

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Fri Dec 15, 2017 7:19 am
by FordGT90Concept
12/13 achievementtest

-Amendment to the above: "his mind is filled with turmoil and regret" triggered in the Ice Cave, followed by R25's line and 212121 shows up on opening the automap (that is still broken); however, even having a visible waypoint to 212121, The Voice encounter still doesn't trigger. It's impossible to test violent achievements because of this.

-As discussed in Discord, "Freefall suit" convo never appears when importing a save.

Lobby Stuffs

https://youtu.be/QI-n004ZiG0
https://youtu.be/EQi5fgqbQT8
Two things happening here: 1) I think this is the same group of guards in the video above and 2) after I finished the conversation with Odin ended with accepting the TTCore objective, Odin's conversation restarted (can see it at the top of the pic). I hit "Move On" and it repeated again. I hit "Move On" again and the squad turned hostile:
► Show Spoiler
https://youtu.be/82lSUUMDK_A

Guard got stuck under the nanite ramp in the lobby:
► Show Spoiler

TTCore Stuffs

-The fast moving platforms in TTCore have the same issue that the elevators did: if you start flying on them, the platform can move through you. They're moving too fast for PhysX to catch the collision.

-Haven't 100% confirmed this yet but have a strong suspicion that you can duplicate the shotguns by picking up the guns off of dead guards at the bottom of TTCore, save, then load again. The load brings the dead guards back so they can be looted again.


UI Stuffs

https://youtu.be/Xw2uA8PslL4

Yellow transponder key, when in one of the PCU external slots, renders flipped on the Y-axis so "Card" ends up being mirrored. It appears correctly when in one of the PCU slots:
► Show Spoiler
Stacks of shields and weapons don't give the stack transfer pop up to move many. It was super annoying trying to collect all the goods Elon needs from Odin's chest.

Death by Assault Blaster apparently shows up as "radioactive energy" damage. This surprised me because that gun doesn't give the impression of being a rad weapon.


Turret of Doom Strikes Again!

Free flight suit with no upgrades, two Consortium shield nodes, death in 22 frames at 30 frame per second = 0.73 seconds:
https://youtu.be/tM4PC-Wm32c
Attaching the save just before this. Doubt it will replicate but maybe there's hope:
save.zip
(3.68 MiB) Downloaded 53 times
-Not a turret of doom but the rocket launcher at the top of the Park managed to kill me in three shots with the same setup.


Conversations

-At the end of the Elon convo where you found out he was responsible for Felixstowe + accepted mission to arm him, VO says "Consortium mandate" but subtitles say "Consortium protocol"

-The "Yellow Transponder Key" conversation doesn't appear unless Elon gives it to you. Should appear when you get it no matter how you get it.

-On the K15 line when approaching Odin, subtitles show "What a nice guy...what have we got on him?" The voice over only says "What a nice guy" then it jumps right into R25.

-There still persists an issue where if you hit escape during a conversation, there's like a delay of silence before the conversation progresses when unpausing. Seems to happen randomly and (perhaps always) when in a direct conversation (not CMC).


Performance

-Tried Radeon Adrenaline driver. Still get pulsing issues with vsync enabled in game. When vsync is disabled, the game appears to be capped at 62 fps on my 60 Hz monitor. FPS at the main menu should be much higher.

-Observed FPS of 25-26 in the lobby while staring at Odin. CPU, RAM, disk, weren't maxing out. GPU was around 75-78%. It doesn't make sense to me why the FPS is so low when nothing is maxing out.

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Fri Dec 15, 2017 7:53 pm
by fanatictentacle
Hey I've got a completly new bug:
Since I have an Oculus Rift now, every time I want to launch the game the oculus software opens up, and remaps the audio output to the rift. Of course there is no video output on it, but I cant get the audio back on the speakers. Aditionally the background services eat up some cpu power. I dont know why the oculus software thinks that The Tower is an oculus title.

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Fri Dec 15, 2017 8:44 pm
by FordGT90Concept
12/13 achievementtest

I tried getting past the OP turret with Buddha mode and...well...
https://youtu.be/PnKvfvCmBwE


I flipped the switch for Preban then found another turret on the same floor that I killed. This triggered a dialog starting with R25 and ending with K15 that said something to the effect of "that's the last of them" then something about Preban's switch...that I already flipped. Dialog shouldn't trigger if the switch is already flipped.

Still a hole out of the TTCore:
https://youtu.be/wc7YGrLAXIk

...haven't found how to turn off power to TTCore water yet...

...I cheated and still can't find a way in there. Remember: automap broken.

Near the path to Odin's switch, I recycled this stuff but is visibly still there and not interactible:
► Show Spoiler
I closed the game down because Odin breaking annoyed me, and loaded again to see if I can make Elon happy instead, and R9 thinks I'm by the Odin switch:
r9load.zip
(3.33 MiB) Downloaded 57 times
https://youtu.be/75YAW-Oo7qQ


I like that Elon's Supply Chest takes what it needs but it's a little *too* greedy. It took all of my 716 KAR bullets and even took shield nodes I had equipped in my free flight suit.


Mouse wheel doesn't work over the PCU Storage area of the UI.

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Sat Dec 16, 2017 2:38 am
by FordGT90Concept
12/13 achievementtest

Famosa is just as broken as the Voice. I got captured, I didn't lose my PCU, and Famosa never came. I went to the area without getting captured and he never started speaking to me. I uploaded the video of this because:
1) Turrets on the solar array generally don't attack. Beginning of video.
2) Getting up the solar array is difficult.
3) Famosa obviously doesn't make an appearance. Midpoint of video.
4) The elevator shaft next to this area seems like a dead end/worthless.
5) The duct next to the elevator shaft has an object clipping into it so I can't get by it. Literally last thing in the video.
https://youtu.be/W5i7hIagJe8


So conversation starting with rooftop squad has some options that don't make sense. Starts with...
Seeker: Hey, why aren't you shooting at me?
Squad Member 1: That's a damn good question isn't it? Maybe it's because you're not a threat, and my boss is an idiot.
Rook 25: What was that?
Rook 9: Certainly isn't Al Qaeda.
The choice that doesn't make sense is: Yeah it is a good question, and what's the answer?

I don't understand it.


Equipping or unequipping stops actively repairing it.

Should add a "Turrets Destroyed" metric to the "Career Record" display.

The turrets killed achievements seem to be linked to number killed in a single instance rather than a global variable spanning multiple plays. Should probably make that clear in the description.

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Mon Dec 18, 2017 1:32 pm
by DevourMistress
Automap location of Toxic save sphere, that corrupted by save file after saving there.
Image

Re: EA Alpha 1.3 Bugs! Comments! Discussions!

Posted: Mon Dec 18, 2017 2:24 pm
by DevourMistress
Save file where i'm trapped in room between rooftop and park. Game crashes when trying to exit said room. Enjoy